<!DOCTYPE html>
<!--[if IE 7]>
<html id="ie7" lang="en">
<![endif]-->
<!--[if (gt IE 7) | (!IE)]><!-->
<html lang="en">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<title>Digging into regressions | 3.1415926535897932384626433...</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://elvis314.wordpress.com/xmlrpc.php" />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.pubmine.com' />
<link rel='dns-prefetch' href='//x.bidswitch.net' />
<link rel='dns-prefetch' href='//static.criteo.net' />
<link rel='dns-prefetch' href='//ib.adnxs.com' />
<link rel='dns-prefetch' href='//aax.amazon-adsystem.com' />
<link rel='dns-prefetch' href='//bidder.criteo.com' />
<link rel='dns-prefetch' href='//cas.criteo.com' />
<link rel='dns-prefetch' href='//gum.criteo.com' />
<link rel='dns-prefetch' href='//ads.pubmatic.com' />
<link rel='dns-prefetch' href='//gads.pubmatic.com' />
<link rel='dns-prefetch' href='//tpc.googlesyndication.com' />
<link rel='dns-prefetch' href='//ad.doubleclick.net' />
<link rel='dns-prefetch' href='//googleads.g.doubleclick.net' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//cdn.switchadhub.com' />
<link rel='dns-prefetch' href='//delivery.g.switchadhub.com' />
<link rel='dns-prefetch' href='//delivery.swid.switchadhub.com' />
<link rel="alternate" type="application/rss+xml" title="3.1415926535897932384626433... &raquo; Feed" href="https://elvis314.wordpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="3.1415926535897932384626433... &raquo; Comments Feed" href="https://elvis314.wordpress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="3.1415926535897932384626433... &raquo; Digging into regressions Comments Feed" href="https://elvis314.wordpress.com/2019/08/23/digging-into-regressions/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1556893897h&ver=5.2.3-RC1-45882"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJyNVNFygyAQ/KEisZPavnT6LaAXvAjCcFCbvy9obEzSMHnRW9zdO45DPjnW2jHAGLiJzOmocCQ+udYaRgY1nG5Q1RK98I1MaqsuQus70RFX2kqhn+M61K23E/t+veNvSvKgRYCOOUvhBpVkGgcgfoTgRDuwGd3RV66KCUrwKn3xwJvqtdpxGVF3ufBZLr3wJ07hpOEJm1lFPOA4gF/RYli2aO2ZXFd1LqJDCksNVC3K2eWh/hC1ZoQBGHSY0q9N57uqqWo+dy3thsJS1OJ/u1pqa25QWjdOhMwwKY0ADSbRSrIJOwXp+BLlHLMAP0WJcc2aKIe9yD0opZiHVUrngYilp8FoWOhTbfe6ZZm7KNcpfHAw/+wBYvpqBwSmxcQDGJdHkrYGyEcbMHnQX1ByVmBZarwIaMcrwA5aoC/fjny1Uqjm3l5gSSTabC6Fv0Qlep6PpRJOvfA51/ldUpFtUei0FWWvwaPD6Pebv8eX+azfmmb/Xn/sm+MvF1XBbQ==?cssminify=yes' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFj+EKAiEQhF8oT+Lw6E/0LOZtsqarudpRT59C/eg4ChaWYT9mZuWSBJLxdQaWrs2tQn681+B4J38BIqDNusAQkD6wiVSASmdT5BKAWVvYuIZ4Rg+iMuQGUGkxl7jmQhXJV4vEMoNvUbPoriu14f79CNIdYfmLOShJm6vIwPjsnU/huFfqMKppUqN7ATNIcHo='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1530132353h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://elvis314.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Recent fixes to reduce backlog on Android&nbsp;phones' href='https://elvis314.wordpress.com/2019/07/17/1872/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://elvis314.wordpress.com/2019/08/23/digging-into-regressions/" />
<link rel='shortlink' href='https://wp.me/pvS5d-uf' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Felvis314.wordpress.com%2F2019%2F08%2F23%2Fdigging-into-regressions%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Felvis314.wordpress.com%2F2019%2F08%2F23%2Fdigging-into-regressions%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Digging into regressions" />
<meta property="og:url" content="https://elvis314.wordpress.com/2019/08/23/digging-into-regressions/" />
<meta property="og:description" content="Whenever a patch is landed on autoland, it will run many builds and tests to make sure there are no regressions.  Unfortunately many times we find a regression and 99% of the time backout the chang…" />
<meta property="article:published_time" content="2019-08-23T20:53:47+00:00" />
<meta property="article:modified_time" content="2019-08-23T21:28:01+00:00" />
<meta property="og:site_name" content="3.1415926535897932384626433..." />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@wordpressdotcom" />
<meta name="twitter:text:title" content="Digging into regressions" />
<meta name="twitter:card" content="summary" />
<meta property="fb:app_id" content="249643311490" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon-precomposed" href="https://s2.wp.com/i/webclip.png" />
<link rel='openid.server' href='https://elvis314.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://elvis314.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://elvis314.wordpress.com/osd.xml" title="3.1415926535897932384626433..." />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="application-name" content="3.1415926535897932384626433..." /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="PI, pie, and py" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://elvis314.wordpress.com/feed/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="Whenever a patch is landed on autoland, it will run many builds and tests to make sure there are no regressions.  Unfortunately many times we find a regression and 99% of the time backout the changes so they can be fixed.  This work is done by the Sheriff team at Mozilla- they monitor the trees&hellip;" />
		<script type="text/javascript">
		function __ATA_CC() {var v = document.cookie.match('(^|;) ?personalized-ads-consent=([^;]*)(;|$)');return v ? 1 : 0;}
		var __ATA_PP = { pt: 1, ht: 0, tn: 'pilcrow', amp: false, siteid: 8982, blogid: 7596067, consent: __ATA_CC() };
		var __ATA = __ATA || {};
		__ATA.cmd = __ATA.cmd || [];
		__ATA.criteo = __ATA.criteo || {};
		__ATA.criteo.cmd = __ATA.criteo.cmd || [];
		</script>
		<script type="text/javascript" src="//s.pubmine.com/head.js" async></script><link rel="amphtml" href="https://elvis314.wordpress.com/2019/08/23/digging-into-regressions/amp/"><script type="text/javascript">
	window.google_analytics_uacct = "UA-52447-2";
</script>

<script type="text/javascript">
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-52447-2']);
	_gaq.push(['_gat._anonymizeIp']);
	_gaq.push(['_setDomainName', 'wordpress.com']);
	_gaq.push(['_initData']);
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(ga);
	})();
</script>
</head>

<body class="post-template-default single single-post postid-1875 single-format-standard mp6 customizer-styles-applied two-column content-sidebar color-light highlander-enabled highlander-light">
<div id="container" class="hfeed">
	<div id="page" class="blog">
		<div id="header">
						<div id="site-title">
				<span>
					<a href="https://elvis314.wordpress.com/" title="3.1415926535897932384626433&#8230;" rel="home">3.1415926535897932384626433&#8230;</a>
				</span>
			</div>

			<div id="nav" role="navigation">
			  				<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">Skip to content</a></div>
								<div class="menu"><ul>
<li ><a href="https://elvis314.wordpress.com/">Home</a></li><li class="page_item page-item-2"><a href="https://elvis314.wordpress.com/about/">About</a></li>
</ul></div>
			</div><!-- #nav -->

			<div id="pic">
				<a href="https://elvis314.wordpress.com/" rel="home">
										<img src="https://s0.wordpress.com/wp-content/themes/pub/pilcrow/images/headers/books.jpg?m=1391151917h" width="770" height="200" alt="" />
								</a>
			</div><!-- #pic -->
		</div><!-- #header -->

		<div id="content-box">

<div id="content-container">
	<div id="content" role="main">

	
<div id="nav-above" class="navigation">
	<div class="nav-previous"><a href="https://elvis314.wordpress.com/2019/07/17/1872/" rel="prev"><span class="meta-nav">&larr;</span> Recent fixes to reduce backlog on Android&nbsp;phones</a></div>
	<div class="nav-next"></div>
</div><!-- #nav-above -->

<div id="post-1875" class="post-1875 post type-post status-publish format-standard hentry category-data category-testdev">
	<div class="entry-meta">

		August 23, 2019 &middot; 4:53 pm	</div><!-- .entry-meta -->

		<div class="jump"><a href="https://elvis314.wordpress.com/2019/08/23/digging-into-regressions/#comments"><span class="meta-nav">&darr; </span>Jump to Comments</a></div>
	<h1 class="entry-title"><a href="https://elvis314.wordpress.com/2019/08/23/digging-into-regressions/" rel="bookmark">Digging into regressions</a></h1>
	<div class="entry entry-content">
		<p>Whenever a patch is landed on <a href="https://treeherder.mozilla.org/#/jobs?repo=autoland">autoland</a>, it will run many builds and tests to make sure there are no regressions.  Unfortunately many times we find a regression and 99% of the time backout the changes so they can be fixed.  This work is done by the Sheriff team at Mozilla- they monitor the trees and when something is wrong, they work to fix it (sometimes by a quick fix, usually by a backout).  A quick fact, there were 1228 regressions in H1 (January-June) 2019.</p>
<p>My goal in writing is not to recommend change, but instead to start conversations and figure out what data we should be collecting in order to have data driven discussions.  Only then would I expect that recommendations for changes would come forth.</p>
<p>What got me started in looking at regressions was trying to answer a question: <em><strong>&#8220;How many regressions did X catch?&#8221;</strong></em>  This alone is a tough question, instead I think the question should be <em><strong>&#8220;If we were not running X, how many regressions would our end users see?&#8221;  </strong></em>This is a much different question and has two distinct parts:</p>
<ul>
<li><em>Unique Regressions</em>: Only look at regressions found that only X found, not found on both X and Y</li>
<li><em>Product Fixes</em>: did the regression result in changing code that we ship to users? (i.e. not editing the test)</li>
<li><em>Final Fix</em>: many times a patch [set] lands and is backed out multiple times, in this case do we look at each time it was backed out, or only the change from initial landing to final landing?</li>
</ul>
<p>These can be more difficult to answer.  For example, Product Fixes- maybe by editing the test case we are preventing a regression in the future because the test is more accurate.</p>
<p>In addition we need to understand how accurate the data we are using is.  As the sheriffs do a great job, they are human and humans make judgement calls.  In this case once a job is marked as &#8220;fixed_by_commit&#8221;, then we cannot go back in and edit it, so a typo or bad data will result in incorrect data.  To add to it, often times multiple patches are backed out at the same time, so is it correct to say that changes from bug A and bug B should be considered?</p>
<p>This year I have looked at this data many times to answer:</p>
<ul>
<li>how many unique regressions did <a href="https://groups.google.com/forum/#!searchin/mozilla.dev.platform/linux32|sort:date/mozilla.dev.platform/82cCNuWcXCk/fA_gxdOTCwAJ">linux32</a> catch?</li>
<li>how many unique regressions did <a href="https://groups.google.com/forum/#!searchin/mozilla.dev.platform/opt$20pgo%7Csort:date/mozilla.dev.platform/0dYGajwXCBc/zzgeaJeqBQAJ">opt tests catch vs pgo</a>?</li>
<li>how many regressions did <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1572820">web-platform-tests</a> catch?
<ul>
<li><em>In H1 &#8211; 90 regressions, 17 product changes</em></li>
</ul>
</li>
</ul>
<p>This data is important to harvest because if we were to turn off a set of jobs or run them as tier-2 we would end up missing regressions.  But if all we miss is editing manifests to disable failing tests, then we are getting no value from the test jobs- so it is important to look at what the regression outcome was.</p>
<p>In fact every time I did this I would run an <a href="https://github.com/mozilla/active-data-recipes">active-data-recipe</a> (<a href="https://github.com/jmaher/active-data-recipes/tree/hacking">fbc recipe in my repo</a>) and have a large pile of data I needed to sort through and manually check.  I spent some time every day for a few weeks looking at regressions and now I have looked at 700 (bugs/changesets).  I found that in manually checking regressions, the end results fell into buckets:</p>
<table dir="ltr" border="1" cellspacing="0" cellpadding="0">
<colgroup>
<col width="136" />
<col width="100" />
<col width="100" /></colgroup>
<tbody>
<tr>
<td>test</td>
<td>196</td>
<td>28.00%</td>
</tr>
<tr>
<td>product</td>
<td>272</td>
<td>38.86%</td>
</tr>
<tr>
<td>manifest</td>
<td>134</td>
<td>19.14%</td>
</tr>
<tr>
<td>unknown</td>
<td>48</td>
<td>6.86%</td>
</tr>
<tr>
<td>backout</td>
<td>27</td>
<td>3.86%</td>
</tr>
<tr>
<td>infra</td>
<td>23</td>
<td>3.29%</td>
</tr>
</tbody>
</table>
<p>Keep in mind that many of the changes which end up in mozilla-central are not only product bugs, but infrastructure bugs, test editing, etc.</p>
<p>After looking at many of these bugs, I found that ~80% of the time things are straightforward (single patch [set] landed, backed out once, relanded with clear comments).  Data I would like to have easily available via a query:</p>
<ul>
<li>Files that are changed between backout and relanding (even if it is a new patch).</li>
<li>A reason as part of phabricator that when we reland, it is required to have a few pre canned fields</li>
</ul>
<p>Ideally this set of data would exist for not only backouts, but for anything that is landed to fix a regression (linting, build, manifest, typo).</p>
<div id="atatags-370373-5d6061725a007">
        <script type="text/javascript">
            __ATA.cmd.push(function() {
                __ATA.initVideoSlot('atatags-370373-5d6061725a007', {
                    sectionId: '370373',
                    format: 'inread'
                });
            });
        </script>
    </div>			<div class="wpcnt">
				<div class="wpa wpmrec">
					<span class="wpa-about">Advertisements</span>
					<div class="u">		<div style="padding-bottom:15px;width:300px;height:250px;float:left;margin-right:5px;margin-top:0px">
			<div id="atatags-26942-5d6061725a047">
				<script type="text/javascript">
				__ATA.cmd.push(function() {
					__ATA.initSlot('atatags-26942-5d6061725a047',  {
						collapseEmpty: 'before',
						sectionId: '26942',
						location: 120,
						width: 300,
						height: 250
					});
				});
				</script>
			</div>
		</div>		<div style="padding-bottom:15px;width:300px;height:250px;float:left;margin-top:0px">
			<div id="atatags-114160-5d6061725a04f">
				<script type="text/javascript">
				__ATA.cmd.push(function() {
					__ATA.initSlot('atatags-114160-5d6061725a04f',  {
						collapseEmpty: 'before',
						sectionId: '114160',
						location: 130,
						width: 300,
						height: 250
					});
				});
				</script>
			</div>
		</div></div>
					
				</div>
			</div><div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-1875" class="share-twitter sd-button share-icon" href="https://elvis314.wordpress.com/2019/08/23/digging-into-regressions/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-1875" class="share-facebook sd-button share-icon" href="https://elvis314.wordpress.com/2019/08/23/digging-into-regressions/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-7596067-1875-5d6061725a8c3' data-src='//widgets.wp.com/likes/index.html?ver=20190321#blog_id=7596067&amp;post_id=1875&amp;origin=elvis314.wordpress.com&amp;obj_id=7596067-1875-5d6061725a8c3' data-name='like-post-frame-7596067-1875-5d6061725a8c3'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>	</div><!-- .entry-content -->

	<div class="entry-links">
		<p class="comment-number"><a href="https://elvis314.wordpress.com/2019/08/23/digging-into-regressions/#respond">Leave a comment</a></p>

					<p class="entry-categories tagged">Filed under <a href="https://elvis314.wordpress.com/category/data/" rel="category tag">data</a>, <a href="https://elvis314.wordpress.com/category/testdev/" rel="category tag">testdev</a></p>
			<p class="entry-tags tagged"></p>
			</div><!-- .entry-links -->

</div><!-- #post-## -->

<div id="nav-below" class="navigation">
	<div class="nav-previous"><a href="https://elvis314.wordpress.com/2019/07/17/1872/" rel="prev"><span class="meta-nav">&larr;</span> Recent fixes to reduce backlog on Android&nbsp;phones</a></div>
	<div class="nav-next"></div>
</div><!-- #nav-below -->


<div id="comments">

	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/08/23/digging-into-regressions/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://elvis314.wordpress.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="ebca46061a" /><input type="hidden" name="_wp_http_referer" value="/2019/08/23/digging-into-regressions/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">
	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" class="nascar-signin-link"
                   title="Login via Guest">
									</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" class="nascar-signin-link"
                   title="Login via WordPress.com">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg>				</a>
			</li>
			<li>
			<iframe id="googleplus-sign-in" name="googleplus-sign-in" src="https://public-api.wordpress.com/connect/?googleplus-sign-in=https%3A%2F%2Felvis314.wordpress.com&#038;color_scheme=light" width="24" height="24" scrolling="no" allowtransparency="true" seamless="seamless" frameborder="0"></iframe>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" class="nascar-signin-link"
                   title="Login via Twitter">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" class="nascar-signin-link"
                   title="Login via Facebook">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg>				</a>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
			
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
						<p class="comment-form-posting-as pa-wordpress">
			<strong></strong>
			You are commenting using your WordPress.com account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Google photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
						<p class="comment-form-posting-as pa-googleplus">
			<strong></strong>
			You are commenting using your Google account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" x="0px" y="0px" viewBox="0 0 60 60" ><path fill="#519bf7" d="M56.3,30c0,-1.6 -0.2,-3.4 -0.6,-5h-3.1H42.2H30v10.6h14.8C44,39.3 42,42 39.1,43.9l8.8,6.8C53,46 56.3,39 56.3,30z" /><path fill="#3db366" d="M30,57.5c6.7,0 13.1,-2.4 17.9,-6.8l-8.8,-6.8c-2.5,1.6 -5.6,2.4 -9.1,2.4c-7.2,0 -13.3,-4.7 -15.4,-11.2l-9.3,7.1C9.8,51.3 19.1,57.5 30,57.5z" /><path fill="#fdc600" d="M5.3,42.2l9.3,-7.1c-0.5,-1.6 -0.8,-3.3 -0.8,-5.1s0.3,-3.5 0.8,-5.1l-9.3,-7.1C3.5,21.5 2.5,25.6 2.5,30S3.5,38.5 5.3,42.2z" /><path fill="#f15b44" d="M40.1,17.4l8,-8C43.3,5.1 37,2.5 30,2.5C19.1,2.5 9.8,8.7 5.3,17.8l9.3,7.1c2.1,-6.5 8.2,-11.1 15.4,-11.1C33.9,13.7 37.4,15.1 40.1,17.4z" /></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
						<p class="comment-form-posting-as pa-twitter">
			<strong></strong>
			You are commenting using your Twitter account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
						<p class="comment-form-posting-as pa-facebook">
			<strong></strong>
			You are commenting using your Facebook account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1875' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="a9aba667c3" /></p>
<input type="hidden" name="genseq" value="1566597490" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="250"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>
</div><!-- #comments -->

	</div><!-- #content -->
</div><!-- #container -->


	<div id="sidebar" class="widget-area" role="complementary">
				<ul class="xoxo sidebar-list">

			<li id="text-2" class="widget widget_text"><h3 class="widget-title">whoami</h3>			<div class="textwidget">My real name is Joel Maher and as you can figure, I am a big fan of PI.  Many people know me by the nick elvis314 or jmaher.  Thanks for reading my blog</div>
		</li><li id="wp_tag_cloud-2" class="widget wp_widget_tag_cloud"><h3 class="widget-title"></h3><div style="overflow:hidden"><a href="https://elvis314.wordpress.com/tag/addons/" class="tag-cloud-link tag-link-106614 tag-link-position-1" style="font-size: 9.8260869565217pt;" aria-label="addons (2 items)">addons</a>
<a href="https://elvis314.wordpress.com/tag/android/" class="tag-cloud-link tag-link-641922 tag-link-position-2" style="font-size: 8pt;" aria-label="android (1 item)">android</a>
<a href="https://elvis314.wordpress.com/tag/automation/" class="tag-cloud-link tag-link-44070 tag-link-position-3" style="font-size: 18.347826086957pt;" aria-label="automation (20 items)">automation</a>
<a href="https://elvis314.wordpress.com/tag/browser-chrome/" class="tag-cloud-link tag-link-10638781 tag-link-position-4" style="font-size: 8pt;" aria-label="browser-chrome (1 item)">browser-chrome</a>
<a href="https://elvis314.wordpress.com/tag/bugs/" class="tag-cloud-link tag-link-6354 tag-link-position-5" style="font-size: 11.04347826087pt;" aria-label="bugs (3 items)">bugs</a>
<a href="https://elvis314.wordpress.com/tag/business/" class="tag-cloud-link tag-link-179 tag-link-position-6" style="font-size: 8pt;" aria-label="business (1 item)">business</a>
<a href="https://elvis314.wordpress.com/tag/code/" class="tag-cloud-link tag-link-656 tag-link-position-7" style="font-size: 14.086956521739pt;" aria-label="code (7 items)">code</a>
<a href="https://elvis314.wordpress.com/tag/community/" class="tag-cloud-link tag-link-2528 tag-link-position-8" style="font-size: 16.623188405797pt;" aria-label="Community (13 items)">Community</a>
<a href="https://elvis314.wordpress.com/tag/contribution/" class="tag-cloud-link tag-link-59800 tag-link-position-9" style="font-size: 13.579710144928pt;" aria-label="contribution (6 items)">contribution</a>
<a href="https://elvis314.wordpress.com/tag/data/" class="tag-cloud-link tag-link-22379 tag-link-position-10" style="font-size: 12.869565217391pt;" aria-label="data (5 items)">data</a>
<a href="https://elvis314.wordpress.com/tag/database/" class="tag-cloud-link tag-link-475 tag-link-position-11" style="font-size: 8pt;" aria-label="database (1 item)">database</a>
<a href="https://elvis314.wordpress.com/tag/debugging/" class="tag-cloud-link tag-link-70886 tag-link-position-12" style="font-size: 9.8260869565217pt;" aria-label="debugging (2 items)">debugging</a>
<a href="https://elvis314.wordpress.com/tag/development/" class="tag-cloud-link tag-link-780 tag-link-position-13" style="font-size: 12.869565217391pt;" aria-label="development (5 items)">development</a>
<a href="https://elvis314.wordpress.com/tag/fennec/" class="tag-cloud-link tag-link-663518 tag-link-position-14" style="font-size: 20.782608695652pt;" aria-label="fennec (35 items)">fennec</a>
<a href="https://elvis314.wordpress.com/tag/fennecmark/" class="tag-cloud-link tag-link-21459199 tag-link-position-15" style="font-size: 11.04347826087pt;" aria-label="fennecmark (3 items)">fennecmark</a>
<a href="https://elvis314.wordpress.com/tag/firefox/" class="tag-cloud-link tag-link-45 tag-link-position-16" style="font-size: 9.8260869565217pt;" aria-label="firefox (2 items)">firefox</a>
<a href="https://elvis314.wordpress.com/tag/geolocation/" class="tag-cloud-link tag-link-108693 tag-link-position-17" style="font-size: 8pt;" aria-label="geolocation (1 item)">geolocation</a>
<a href="https://elvis314.wordpress.com/tag/gps/" class="tag-cloud-link tag-link-3169 tag-link-position-18" style="font-size: 8pt;" aria-label="gps (1 item)">gps</a>
<a href="https://elvis314.wordpress.com/tag/graph-server/" class="tag-cloud-link tag-link-21542873 tag-link-position-19" style="font-size: 8pt;" aria-label="graph server (1 item)">graph server</a>
<a href="https://elvis314.wordpress.com/tag/gsoc/" class="tag-cloud-link tag-link-151852 tag-link-position-20" style="font-size: 8pt;" aria-label="gsoc (1 item)">gsoc</a>
<a href="https://elvis314.wordpress.com/tag/hacking/" class="tag-cloud-link tag-link-1816 tag-link-position-21" style="font-size: 11.04347826087pt;" aria-label="hacking (3 items)">hacking</a>
<a href="https://elvis314.wordpress.com/tag/hardware/" class="tag-cloud-link tag-link-79 tag-link-position-22" style="font-size: 8pt;" aria-label="hardware (1 item)">hardware</a>
<a href="https://elvis314.wordpress.com/tag/howto/" class="tag-cloud-link tag-link-1921 tag-link-position-23" style="font-size: 14.086956521739pt;" aria-label="howto (7 items)">howto</a>
<a href="https://elvis314.wordpress.com/tag/idea/" class="tag-cloud-link tag-link-2933 tag-link-position-24" style="font-size: 12.869565217391pt;" aria-label="idea (5 items)">idea</a>
<a href="https://elvis314.wordpress.com/tag/ideas/" class="tag-cloud-link tag-link-374 tag-link-position-25" style="font-size: 8pt;" aria-label="Ideas (1 item)">Ideas</a>
<a href="https://elvis314.wordpress.com/tag/intermittent-failures/" class="tag-cloud-link tag-link-146336932 tag-link-position-26" style="font-size: 12.057971014493pt;" aria-label="intermittent-failures (4 items)">intermittent-failures</a>
<a href="https://elvis314.wordpress.com/tag/linkedin/" class="tag-cloud-link tag-link-80962 tag-link-position-27" style="font-size: 11.04347826087pt;" aria-label="linkedin (3 items)">linkedin</a>
<a href="https://elvis314.wordpress.com/tag/manifest/" class="tag-cloud-link tag-link-24992 tag-link-position-28" style="font-size: 8pt;" aria-label="manifest (1 item)">manifest</a>
<a href="https://elvis314.wordpress.com/tag/manifests/" class="tag-cloud-link tag-link-44951 tag-link-position-29" style="font-size: 8pt;" aria-label="manifests (1 item)">manifests</a>
<a href="https://elvis314.wordpress.com/tag/mentoring/" class="tag-cloud-link tag-link-33253 tag-link-position-30" style="font-size: 8pt;" aria-label="Mentoring (1 item)">Mentoring</a>
<a href="https://elvis314.wordpress.com/tag/mobile/" class="tag-cloud-link tag-link-120 tag-link-position-31" style="font-size: 17.130434782609pt;" aria-label="mobile (15 items)">mobile</a>
<a href="https://elvis314.wordpress.com/tag/mochitest/" class="tag-cloud-link tag-link-23461774 tag-link-position-32" style="font-size: 18.347826086957pt;" aria-label="mochitest (20 items)">mochitest</a>
<a href="https://elvis314.wordpress.com/tag/mozilla/" class="tag-cloud-link tag-link-24 tag-link-position-33" style="font-size: 22pt;" aria-label="mozilla (47 items)">mozilla</a>
<a href="https://elvis314.wordpress.com/tag/notes/" class="tag-cloud-link tag-link-785 tag-link-position-34" style="font-size: 14.086956521739pt;" aria-label="notes (7 items)">notes</a>
<a href="https://elvis314.wordpress.com/tag/numbers/" class="tag-cloud-link tag-link-6180 tag-link-position-35" style="font-size: 8pt;" aria-label="numbers (1 item)">numbers</a>
<a href="https://elvis314.wordpress.com/tag/people/" class="tag-cloud-link tag-link-660 tag-link-position-36" style="font-size: 11.04347826087pt;" aria-label="People (3 items)">People</a>
<a href="https://elvis314.wordpress.com/tag/perf/" class="tag-cloud-link tag-link-1054996 tag-link-position-37" style="font-size: 8pt;" aria-label="Perf (1 item)">Perf</a>
<a href="https://elvis314.wordpress.com/tag/perfherder/" class="tag-cloud-link tag-link-146339237 tag-link-position-38" style="font-size: 8pt;" aria-label="PerfHerder (1 item)">PerfHerder</a>
<a href="https://elvis314.wordpress.com/tag/performance/" class="tag-cloud-link tag-link-1930 tag-link-position-39" style="font-size: 16.623188405797pt;" aria-label="performance (13 items)">performance</a>
<a href="https://elvis314.wordpress.com/tag/performance-testing/" class="tag-cloud-link tag-link-11154 tag-link-position-40" style="font-size: 8pt;" aria-label="performance testing (1 item)">performance testing</a>
<a href="https://elvis314.wordpress.com/tag/personal/" class="tag-cloud-link tag-link-64 tag-link-position-41" style="font-size: 11.04347826087pt;" aria-label="personal (3 items)">personal</a>
<a href="https://elvis314.wordpress.com/tag/policy/" class="tag-cloud-link tag-link-13217 tag-link-position-42" style="font-size: 8pt;" aria-label="policy (1 item)">policy</a>
<a href="https://elvis314.wordpress.com/tag/process/" class="tag-cloud-link tag-link-9719 tag-link-position-43" style="font-size: 9.8260869565217pt;" aria-label="process (2 items)">process</a>
<a href="https://elvis314.wordpress.com/tag/projects/" class="tag-cloud-link tag-link-2008 tag-link-position-44" style="font-size: 8pt;" aria-label="projects (1 item)">projects</a>
<a href="https://elvis314.wordpress.com/tag/python/" class="tag-cloud-link tag-link-832 tag-link-position-45" style="font-size: 8pt;" aria-label="python (1 item)">python</a>
<a href="https://elvis314.wordpress.com/tag/qa/" class="tag-cloud-link tag-link-8841 tag-link-position-46" style="font-size: 8pt;" aria-label="qa (1 item)">qa</a>
<a href="https://elvis314.wordpress.com/tag/random-orange/" class="tag-cloud-link tag-link-44877966 tag-link-position-47" style="font-size: 8pt;" aria-label="random orange (1 item)">random orange</a>
<a href="https://elvis314.wordpress.com/tag/rant/" class="tag-cloud-link tag-link-287 tag-link-position-48" style="font-size: 8pt;" aria-label="rant (1 item)">rant</a>
<a href="https://elvis314.wordpress.com/tag/reftest/" class="tag-cloud-link tag-link-21460549 tag-link-position-49" style="font-size: 13.579710144928pt;" aria-label="reftest (6 items)">reftest</a>
<a href="https://elvis314.wordpress.com/tag/report/" class="tag-cloud-link tag-link-17573 tag-link-position-50" style="font-size: 8pt;" aria-label="Report (1 item)">Report</a>
<a href="https://elvis314.wordpress.com/tag/scheduling/" class="tag-cloud-link tag-link-38754 tag-link-position-51" style="font-size: 8pt;" aria-label="Scheduling (1 item)">Scheduling</a>
<a href="https://elvis314.wordpress.com/tag/seta/" class="tag-cloud-link tag-link-86735 tag-link-position-52" style="font-size: 8pt;" aria-label="SETA (1 item)">SETA</a>
<a href="https://elvis314.wordpress.com/tag/sports/" class="tag-cloud-link tag-link-67 tag-link-position-53" style="font-size: 8pt;" aria-label="sports (1 item)">sports</a>
<a href="https://elvis314.wordpress.com/tag/stair-climbing/" class="tag-cloud-link tag-link-4222456 tag-link-position-54" style="font-size: 8pt;" aria-label="stair climbing (1 item)">stair climbing</a>
<a href="https://elvis314.wordpress.com/tag/startup/" class="tag-cloud-link tag-link-4621 tag-link-position-55" style="font-size: 8pt;" aria-label="startup (1 item)">startup</a>
<a href="https://elvis314.wordpress.com/tag/statistics/" class="tag-cloud-link tag-link-5849 tag-link-position-56" style="font-size: 9.8260869565217pt;" aria-label="Statistics (2 items)">Statistics</a>
<a href="https://elvis314.wordpress.com/tag/talos/" class="tag-cloud-link tag-link-4148726 tag-link-position-57" style="font-size: 16.927536231884pt;" aria-label="talos (14 items)">talos</a>
<a href="https://elvis314.wordpress.com/tag/technology/" class="tag-cloud-link tag-link-6 tag-link-position-58" style="font-size: 8pt;" aria-label="technology (1 item)">technology</a>
<a href="https://elvis314.wordpress.com/tag/testdev/" class="tag-cloud-link tag-link-19937500 tag-link-position-59" style="font-size: 21.086956521739pt;" aria-label="testdev (38 items)">testdev</a>
<a href="https://elvis314.wordpress.com/tag/testing/" class="tag-cloud-link tag-link-12 tag-link-position-60" style="font-size: 9.8260869565217pt;" aria-label="Testing (2 items)">Testing</a>
<a href="https://elvis314.wordpress.com/tag/tests/" class="tag-cloud-link tag-link-2436 tag-link-position-61" style="font-size: 8pt;" aria-label="tests (1 item)">tests</a>
<a href="https://elvis314.wordpress.com/tag/tip/" class="tag-cloud-link tag-link-30930 tag-link-position-62" style="font-size: 8pt;" aria-label="tip (1 item)">tip</a>
<a href="https://elvis314.wordpress.com/tag/tips/" class="tag-cloud-link tag-link-1788 tag-link-position-63" style="font-size: 14.594202898551pt;" aria-label="tips (8 items)">tips</a>
<a href="https://elvis314.wordpress.com/tag/tools/" class="tag-cloud-link tag-link-1981 tag-link-position-64" style="font-size: 18.144927536232pt;" aria-label="tools (19 items)">tools</a>
<a href="https://elvis314.wordpress.com/tag/traffic/" class="tag-cloud-link tag-link-3967 tag-link-position-65" style="font-size: 8pt;" aria-label="traffic (1 item)">traffic</a>
<a href="https://elvis314.wordpress.com/tag/trends/" class="tag-cloud-link tag-link-518 tag-link-position-66" style="font-size: 8pt;" aria-label="trends (1 item)">trends</a>
<a href="https://elvis314.wordpress.com/tag/unittests/" class="tag-cloud-link tag-link-5549356 tag-link-position-67" style="font-size: 19.666666666667pt;" aria-label="unittests (27 items)">unittests</a>
<a href="https://elvis314.wordpress.com/tag/webserver/" class="tag-cloud-link tag-link-28027 tag-link-position-68" style="font-size: 8pt;" aria-label="webserver (1 item)">webserver</a>
<a href="https://elvis314.wordpress.com/tag/wince/" class="tag-cloud-link tag-link-114931 tag-link-position-69" style="font-size: 12.869565217391pt;" aria-label="wince (5 items)">wince</a>
<a href="https://elvis314.wordpress.com/tag/windows-mobile/" class="tag-cloud-link tag-link-1846 tag-link-position-70" style="font-size: 17.942028985507pt;" aria-label="windows mobile (18 items)">windows mobile</a>
<a href="https://elvis314.wordpress.com/tag/xpcshell/" class="tag-cloud-link tag-link-21822950 tag-link-position-71" style="font-size: 15.101449275362pt;" aria-label="xpcshell (9 items)">xpcshell</a></div></li><li id="archives-2" class="widget widget_archive"><h3 class="widget-title">Archives</h3>		<ul>
				<li><a href='https://elvis314.wordpress.com/2019/08/'>August 2019</a></li>
	<li><a href='https://elvis314.wordpress.com/2019/07/'>July 2019</a></li>
	<li><a href='https://elvis314.wordpress.com/2018/09/'>September 2018</a></li>
	<li><a href='https://elvis314.wordpress.com/2018/08/'>August 2018</a></li>
	<li><a href='https://elvis314.wordpress.com/2017/12/'>December 2017</a></li>
	<li><a href='https://elvis314.wordpress.com/2017/11/'>November 2017</a></li>
	<li><a href='https://elvis314.wordpress.com/2017/10/'>October 2017</a></li>
	<li><a href='https://elvis314.wordpress.com/2017/04/'>April 2017</a></li>
	<li><a href='https://elvis314.wordpress.com/2017/03/'>March 2017</a></li>
	<li><a href='https://elvis314.wordpress.com/2017/02/'>February 2017</a></li>
	<li><a href='https://elvis314.wordpress.com/2017/01/'>January 2017</a></li>
	<li><a href='https://elvis314.wordpress.com/2016/10/'>October 2016</a></li>
	<li><a href='https://elvis314.wordpress.com/2016/02/'>February 2016</a></li>
	<li><a href='https://elvis314.wordpress.com/2015/11/'>November 2015</a></li>
	<li><a href='https://elvis314.wordpress.com/2015/10/'>October 2015</a></li>
	<li><a href='https://elvis314.wordpress.com/2015/09/'>September 2015</a></li>
	<li><a href='https://elvis314.wordpress.com/2015/07/'>July 2015</a></li>
	<li><a href='https://elvis314.wordpress.com/2015/06/'>June 2015</a></li>
	<li><a href='https://elvis314.wordpress.com/2015/05/'>May 2015</a></li>
	<li><a href='https://elvis314.wordpress.com/2015/02/'>February 2015</a></li>
	<li><a href='https://elvis314.wordpress.com/2014/12/'>December 2014</a></li>
	<li><a href='https://elvis314.wordpress.com/2014/10/'>October 2014</a></li>
	<li><a href='https://elvis314.wordpress.com/2014/07/'>July 2014</a></li>
	<li><a href='https://elvis314.wordpress.com/2014/06/'>June 2014</a></li>
	<li><a href='https://elvis314.wordpress.com/2014/05/'>May 2014</a></li>
	<li><a href='https://elvis314.wordpress.com/2014/04/'>April 2014</a></li>
	<li><a href='https://elvis314.wordpress.com/2014/03/'>March 2014</a></li>
	<li><a href='https://elvis314.wordpress.com/2014/02/'>February 2014</a></li>
	<li><a href='https://elvis314.wordpress.com/2013/03/'>March 2013</a></li>
	<li><a href='https://elvis314.wordpress.com/2012/07/'>July 2012</a></li>
	<li><a href='https://elvis314.wordpress.com/2012/06/'>June 2012</a></li>
	<li><a href='https://elvis314.wordpress.com/2012/05/'>May 2012</a></li>
	<li><a href='https://elvis314.wordpress.com/2012/03/'>March 2012</a></li>
	<li><a href='https://elvis314.wordpress.com/2011/12/'>December 2011</a></li>
	<li><a href='https://elvis314.wordpress.com/2011/11/'>November 2011</a></li>
	<li><a href='https://elvis314.wordpress.com/2011/10/'>October 2011</a></li>
	<li><a href='https://elvis314.wordpress.com/2011/09/'>September 2011</a></li>
	<li><a href='https://elvis314.wordpress.com/2011/08/'>August 2011</a></li>
	<li><a href='https://elvis314.wordpress.com/2011/05/'>May 2011</a></li>
	<li><a href='https://elvis314.wordpress.com/2011/04/'>April 2011</a></li>
	<li><a href='https://elvis314.wordpress.com/2011/03/'>March 2011</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/11/'>November 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/10/'>October 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/07/'>July 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/06/'>June 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/05/'>May 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/04/'>April 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/03/'>March 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/02/'>February 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/01/'>January 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2009/12/'>December 2009</a></li>
	<li><a href='https://elvis314.wordpress.com/2009/11/'>November 2009</a></li>
	<li><a href='https://elvis314.wordpress.com/2009/09/'>September 2009</a></li>
	<li><a href='https://elvis314.wordpress.com/2009/08/'>August 2009</a></li>
	<li><a href='https://elvis314.wordpress.com/2009/07/'>July 2009</a></li>
	<li><a href='https://elvis314.wordpress.com/2009/06/'>June 2009</a></li>
	<li><a href='https://elvis314.wordpress.com/2009/05/'>May 2009</a></li>
		</ul>
			</li><li id="categories-422543811" class="widget widget_categories"><h3 class="widget-title">Categories</h3>		<ul>
				<li class="cat-item cat-item-2528"><a href="https://elvis314.wordpress.com/category/community/">Community</a> (12)
</li>
	<li class="cat-item cat-item-22379"><a href="https://elvis314.wordpress.com/category/data/">data</a> (1)
</li>
	<li class="cat-item cat-item-54"><a href="https://elvis314.wordpress.com/category/general/">general</a> (16)
</li>
	<li class="cat-item cat-item-113450"><a href="https://elvis314.wordpress.com/category/intermittents/">intermittents</a> (3)
</li>
	<li class="cat-item cat-item-64"><a href="https://elvis314.wordpress.com/category/personal/">personal</a> (4)
</li>
	<li class="cat-item cat-item-8841"><a href="https://elvis314.wordpress.com/category/qa/">qa</a> (4)
</li>
	<li class="cat-item cat-item-309"><a href="https://elvis314.wordpress.com/category/reviews/">reviews</a> (5)
</li>
	<li class="cat-item cat-item-19937500"><a href="https://elvis314.wordpress.com/category/testdev/">testdev</a> (67)
</li>
	<li class="cat-item cat-item-1"><a href="https://elvis314.wordpress.com/category/uncategorized/">Uncategorized</a> (58)
</li>
		</ul>
			</li><li id="linkcat-1356" class="widget widget_links"><h3 class="widget-title">Blogroll</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://cacaolab.wordpress.com/directory-of-artisan-chocolate-makers/" rel="friend met colleague" title="For all you Chocolate fanatics">Cacao Lab</a></li>
<li><a href="http://cmtalbert.wordpress.com/" rel="friend met co-worker" title="Water on Rock &#8211; More mozilla testdev goodness">Clint Talbert &#8211; Mozilla testdev</a></li>
<li><a href="http://zadkielm.blogspot.com/" rel="friend co-worker" title="A great wealth of tidbits on software development and a lot of Mozilla and Fennec">Evmarbella&#039;s Web Log</a></li>
<li><a href="http://sebasti1.wordpress.com/" rel="friend met co-worker" title="Many postings related to software development including work on Mozilla and Fennec">Happyhans</a></li>

	</ul>
</li>
		<div class="wpcnt">
			<div class="wpa wpwidesky">
				<span class="wpa-about">Advertisements</span>
				<div class="u">
							<div style="padding-bottom:15px;width:160px;height:600px;">
			<div id="atatags-286348-5d606172613b7">
				<script type="text/javascript">
				__ATA.cmd.push(function() {
					__ATA.initSlot('atatags-286348-5d606172613b7',  {
						collapseEmpty: 'before',
						sectionId: '286348',
						location: 140,
						width: 160,
						height: 600
					});
				});
				</script>
			</div>
		</div>
				</div>
				
			</div>
		</div>		</ul>
	</div><!-- #sidebar .widget-area -->

	
		</div><!-- #content-box -->

		<div id="footer" role="contentinfo">
			<div id="colophon">

				
				<div id="site-info">
					<a href="https://elvis314.wordpress.com/" title="3.1415926535897932384626433&#8230;" rel="home">3.1415926535897932384626433&#8230;</a> &middot; PI, pie, and py				</div><!-- #site-info -->

				<div id="site-generator">
					<a href="https://wordpress.com/?ref=footer_website">Create a free website or blog at WordPress.com.</a>				</div><!-- #site-generator -->

			</div><!-- #colophon -->
		</div><!-- #footer -->
	</div><!-- #page .blog -->
</div><!-- #container -->

<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201934y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/elvis314.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/elvis314.wordpress.com\/wp-login.php?action=logout&_wpnonce=0f4cfb76b5","homeURL":"https:\/\/elvis314.wordpress.com\/","postID":"1875","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"0","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1551752381j'></script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/elvis314.wordpress.com\/2019\/08\/23\/digging-into-regressions\/":1875};
	</script>
				<div class="widget widget_eu_cookie_law_widget"><div
	class="hide-on-button ads-active"
	data-hide-timeout="30"
	data-consent-expiration="180"
	id="eu-cookie-law"
>
	<form method="post">
		<input type="submit" value="Close and accept" class="accept" />

		Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
		<a href="https://automattic.com/cookies" >
			Cookie Policy		</a>
 </form>
</div>
</div><script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"7596067","siteName":"3.1415926535897932384626433...","siteURL":"http:\/\/elvis314.wordpress.com","icon":"<img alt='' src='https:\/\/s2.wp.com\/i\/logo\/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/pilcrow","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Felvis314.wordpress.com%2F2019%2F08%2F23%2Fdigging-into-regressions%2F&signup_flow=account","themeURL":"","xhrURL":"https:\/\/elvis314.wordpress.com\/wp-admin\/admin-ajax.php","nonce":"10d34a762b","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"a650c15cf8\" \/>","referer":"https:\/\/elvis314.wordpress.com\/2019\/08\/23\/digging-into-regressions\/","canFollow":"1","feedID":"612594","statusMessage":"","customizeLink":"https:\/\/elvis314.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Felvis314.wordpress.com%2F2019%2F08%2F23%2Fdigging-into-regressions%2F","postID":"1875","shortlink":"https:\/\/wp.me\/pvS5d-uf","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/elvis314.wordpress.com\/1875","statsLink":"https:\/\/wordpress.com\/stats\/post\/1875\/elvis314.wordpress.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Pilcrow","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Felvis314.wordpress.com%2F2019%2F08%2F23%2Fdigging-into-regressions%2F&signup_flow=account\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyVUEtuAjEMvVAzpipD2VQ9ShUSM3gmP2yHobdvWIBQF5FY+en9bBnWYlxOiklhFvB4IYflOszyBk9SrKaEOlESCLSgwLlixZNNPiDfzZRcqL6JrcjlGFvQMJbwO0RKncaV/IQqgLWpeSE0wa6gGEuwiv/4To/1bY85WIZoRZEbMvmCzHQ76sG92KBs3SK9kFPK6RZ6oJ57IYmo5mPYwE/7GBwzx46/ZFFzDJYY5GSZ0nSfLfQdv97H3XYcP/f77fwHGAerSg=='></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20190321#ver=20190321' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?60" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'7596067','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'7596067','v':'wpcom','tz':'-4','user_id':'0','post':'1875','subd':'elvis314'}]);
_stq.push(['extra', {'crypt':'UE5XaGUuOTlwaD85flAmcm1mcmZsaDhkV11YdWFnNncxc1tjZG9XVXhRREQ/V0xPZ1hKXy9tT2NrSFYrY21oVW8/aUJWS3VbSUw4amxjLjZzM0ViWUdVSzZxZ0xDODBzU3dseGF2Z3Aldm83QVstcG1oJksmQkpKUHx2TmxsODYsSzVyeTU5em40SHhSPUFjQ2ImWEMtMSZ3SS5ydGpuaHAvfFBRWCVtQ0F0Yj1UP3JURTNRMEVsTmJJWnl5U3d0MERTNTd6WmFYTVVCVCVQdyUrdVVfTkZhJWJ5SjNNV1ZfWitWN3JqaWtXfD9FaGcvNnFzQzgrRS1Wd2M3MWU5RUNrZXxXVnpIZkVCJkQ='}]);
_stq.push([ 'clickTrackerInit', '7596067', '1875' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>
<!--
	generated 186 seconds ago
	generated in 0.108 seconds
	served from batcache in 0.002 seconds
	expires in 114 seconds
-->
