<!DOCTYPE html>
<!--[if IE 7]>
<html id="ie7" lang="en">
<![endif]-->
<!--[if (gt IE 7) | (!IE)]><!-->
<html lang="en">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<title>Project Stockwell &#8211; February 2017 | 3.1415926535897932384626433...</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://elvis314.wordpress.com/xmlrpc.php" />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="3.1415926535897932384626433... &raquo; Feed" href="https://elvis314.wordpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="3.1415926535897932384626433... &raquo; Comments Feed" href="https://elvis314.wordpress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="3.1415926535897932384626433... &raquo; Project Stockwell &#8211; February&nbsp;2017 Comments Feed" href="https://elvis314.wordpress.com/2017/02/07/project-stockwell-february-2017/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1473172720h&ver=4.6.1-RC1-38499"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJyNUttSAyEM/SERa1unL47fEtjI0gbCENad/r3gWntTxhfIyZzDyQU9J2U5FoxFh0klmpyPoudkOSgJnvB4gx6tyIP+XUb+gKL3WBLYg/pCd3RD7M4+nAcYRDtiA/Q/bvJkM8/q47lXSkaCgoNKLOUG9WSWM9Z8SFAaI+DgAQlDpfVkIb2cVC0ca/tdm2WixqSMIqqewU9BlbEa3euWtE6TOfWupRwJF6LXkYuvXPkJes4OWRFbKJ7jFVDvBD73R9r2UUOnK+sC9kRg2+MG8jnq0duClkq0jJCb1/fdUwlbD1RbcXwN/prluLn4cm/hdbXZbbfr3Wr9tP8EJSYnxQ==' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyFj+sKwjAMhV/IrHib+kN8ltrFkdqbTevQpzcD/aEOhUDIyZfDiRoSUDCudsjKSl0q5tuzNZZn6hcAnvqsCzaewgs2MRQMZWR9PJJDqIxZ96KJ0SlOcCly8cgs0MT2PRKFK+HwF7NYkjZnyMh0/3L1FZKrPQVWGZ080MGY4WOSq4Pfz1dtu14sd5utfQAruHB+'></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://elvis314.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Project Stockwell &#8211; January&nbsp;2016' href='https://elvis314.wordpress.com/2017/01/09/project-stockwell-january-2016/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://elvis314.wordpress.com/2017/02/07/project-stockwell-february-2017/" />
<link rel='shortlink' href='http://wp.me/pvS5d-ne' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/1.0/?format=json&amp;url=https%3A%2F%2Felvis314.wordpress.com%2F2017%2F02%2F07%2Fproject-stockwell-february-2017%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/1.0/?format=xml&amp;url=https%3A%2F%2Felvis314.wordpress.com%2F2017%2F02%2F07%2Fproject-stockwell-february-2017%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Project Stockwell &#8211; February 2017" />
<meta property="og:url" content="https://elvis314.wordpress.com/2017/02/07/project-stockwell-february-2017/" />
<meta property="og:description" content="I realized my post for last month was titled &#8220;Project Stockwell &#8211; January 2016&#8221; &#8211; that is a fun typo to make :) Last month we focused on triaging all bugs that met our crite…" />
<meta property="article:published_time" content="2017-02-07T17:22:21+00:00" />
<meta property="article:modified_time" content="2017-02-07T17:32:37+00:00" />
<meta property="og:site_name" content="3.1415926535897932384626433..." />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@wordpressdotcom" />
<meta name="twitter:card" content="summary" />
<meta property="fb:app_id" content="249643311490" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<link rel="shortcut icon" type="image/x-icon" href="https://s2.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s2.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon-precomposed" href="https://s0.wp.com/i/webclip.png" />
<link rel='openid.server' href='https://elvis314.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://elvis314.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://elvis314.wordpress.com/osd.xml" title="3.1415926535897932384626433..." />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="application-name" content="3.1415926535897932384626433..." /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="PI, pie, and py" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://elvis314.wordpress.com/feed/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="title" content="Project Stockwell &#8211; February&nbsp;2017 | 3.1415926535897932384626433... on WordPress.com" />
<meta name="description" content="I realized my post for last month was titled &quot;Project Stockwell - January 2016&quot; - that is a fun typo to make :) Last month we focused on triaging all bugs that met our criteria of &gt;=30 failures/week.  Every day there are many new bugs to triage and we started with a large list.  In&hellip;" />
		<script type="text/javascript" src="//c.amazon-adsystem.com/aax2/amzn_ads.js"></script>
		<script type="text/javascript">
		try { amznads.getAds("3033"); } catch(e) { /* ignore */ }
		</script>
		<script type="text/javascript">
		try {
			var a9_p = amznads.getKeys(),
			_ipw_custom = {
				wordAds: '0',
				adSafe: '0',
				domain: 'elvis314.wordpress.com',
				pageURL: 'https://elvis314.wordpress.com/2017/02/07/project-stockwell-february-2017/'
			};
			if("undefined"!=typeof a9_p&&""!=a9_p&&null!==a9_p&&"[object Array]"===Object.prototype.toString.call(a9_p)){var a="",b=0,c=a9_p.length;a9_p.sort();for(var d=0;d<c;d++){a9_p[d-b]=a9_p[d-b].replace(/a1x6p/,"a160x600p");var e=a9_p[d-b].split("p");e[0]==a&&(a9_p.splice(d-b,1),b++);a=e[0]}_ipw_custom.amznPay=a9_p};document.close();
		} catch(e) {}
		</script> 		<script type="text/javascript" src="https://static.criteo.net/js/ld/publishertag.js"></script>
 		<script type="text/javascript" src="//s.pubmine.com/head.js"></script>
		<script type="text/javascript">
		jQuery(window).ready(function () {
			jQuery("a.wpa-about").text("Advertisements");
		});
		</script><link rel="amphtml" href="https://elvis314.wordpress.com/2017/02/07/project-stockwell-february-2017/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>
<script type="text/javascript">
	window.google_analytics_uacct = "UA-52447-2";
</script>

<script type="text/javascript">
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-52447-2']);
	_gaq.push(['_setDomainName', 'wordpress.com']);
	_gaq.push(['_initData']);
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(ga);
	})();
</script>
</head>

<body class="single single-post postid-1440 single-format-standard mp6 customizer-styles-applied two-column content-sidebar color-light highlander-enabled highlander-light">
<div id="container" class="hfeed">
	<div id="page" class="blog">
		<div id="header">
						<div id="site-title">
				<span>
					<a href="https://elvis314.wordpress.com/" title="3.1415926535897932384626433&#8230;" rel="home">3.1415926535897932384626433&#8230;</a>
				</span>
			</div>

			<div id="nav" role="navigation">
			  				<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">Skip to content</a></div>
								<div class="menu"><ul><li ><a href="https://elvis314.wordpress.com/">Home</a></li><li class="page_item page-item-2"><a href="https://elvis314.wordpress.com/about/">About</a></li></ul></div>
			</div><!-- #nav -->

			<div id="pic">
				<a href="https://elvis314.wordpress.com/" rel="home">
										<img src="https://s0.wordpress.com/wp-content/themes/pub/pilcrow/images/headers/books.jpg?m=1391151917h" width="770" height="200" alt="" />
								</a>
			</div><!-- #pic -->
		</div><!-- #header -->

		<div id="content-box">

<div id="content-container">
	<div id="content" role="main">

	
<div id="nav-above" class="navigation">
	<div class="nav-previous"><a href="https://elvis314.wordpress.com/2017/01/09/project-stockwell-january-2016/" rel="prev"><span class="meta-nav">&larr;</span> Project Stockwell &#8211; January&nbsp;2016</a></div>
	<div class="nav-next"></div>
</div><!-- #nav-above -->

<div id="post-1440" class="post-1440 post type-post status-publish format-standard hentry category-uncategorized">
	<div class="entry-meta">

		February 7, 2017 &middot; 1:22 pm	</div><!-- .entry-meta -->

		<div class="jump"><a href="https://elvis314.wordpress.com/2017/02/07/project-stockwell-february-2017/#comments"><span class="meta-nav">&darr; </span>Jump to Comments</a></div>
	<h1 class="entry-title"><a href="https://elvis314.wordpress.com/2017/02/07/project-stockwell-february-2017/" rel="bookmark">Project Stockwell &#8211; February&nbsp;2017</a></h1>
	<div class="entry entry-content">
		<p>I realized my post for last month was titled &#8220;<a href="https://elvis314.wordpress.com/2017/01/09/project-stockwell-january-2016/">Project Stockwell &#8211; January 2016</a>&#8221; &#8211; that is a fun typo to make 🙂</p>
<p>Last month we focused on triaging all bugs that met our criteria of &gt;=30 failures/week.  Every day there are many new bugs to triage and we started with a large list.  In the end we have commented on all the bugs and have a small list every day to revisit or investigate.</p>
<p>One thing we focus on is only requesting assistance at most once per week- to that note we have a &#8220;<a href="https://people-mozilla.org/~klahnakoski/NeglectedOranges/index.html">Neglected Oranges</a>&#8221; dashboard that we use daily.</p>
<p>What is changing this month- We will be recommending <strong>resolution on priority bugs (&gt;=30 failures/week) in 2 weeks time</strong>.  Resolution is active debugging, landing changes to the test to reduce,debug, or fix the intermittent, or in the case where there is a lack of time or ease of finding a fix disabling the test.  If this goes well, we will reduce that down to 7 days in March.</p>
<p>So how are we doing?</p>
<table style="height:105px;border:1px solid black;" border="1" width="475" rules="NONE" cellspacing="3">
<colgroup>
<col width="80" />
<col width="80" />
<col width="80" /></colgroup>
<tbody style="border:1px solid black;">
<tr style="border:1px solid black;">
<td style="border:1px solid black;" align="LEFT" width="80" height="17">Week starting:</td>
<td style="border:1px solid black;" align="LEFT" width="80">Jan 02, 2017</td>
<td style="border:1px solid black;" align="LEFT" width="80">Jan 30, 2016</td>
</tr>
<tr style="border:1px solid black;">
<td style="border:1px solid black;" align="LEFT" height="17">Orange Factor</td>
<td style="border:1px solid black;" align="RIGHT">13.76</td>
<td style="border:1px solid black;" align="RIGHT">10.75</td>
</tr>
<tr style="border:1px solid black;">
<td style="border:1px solid black;" align="LEFT" height="17"># priority intermittent</td>
<td style="border:1px solid black;" align="RIGHT">42</td>
<td style="border:1px solid black;" align="RIGHT">61</td>
</tr>
</tbody>
</table>
<p>We have less overall failures, but more bugs spread out.  Some interesting bugs:</p>
<ul>
<li><a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1293474">upgrade libxcb</a></li>
<li><a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1332564">disabled webvtt cue processing tests</a> which are from web-platform-tests but not implemented in gecko.</li>
</ul>
<p>In terms of projects underway, here is some status:</p>
<ul>
<li>adding BUG_COMPONENTS to all files in m-c (<a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1328351">bug 1328351</a>) &#8211; slow and steady progress, thanks for the reviews to date!  We expect large majority of this to be completed this month.</li>
<li>retrigger an existing job with additional debugging arguments (<a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1322433">bug 1322433</a>) &#8211; main discussion is done, figuring out small details, should see a prototype this month</li>
<li>add |mach test-info| support (<a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1324470">bug 1324470</a>) &#8211; landed today!</li>
<li>add a test-lint job to linux64/mochitest (<a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1323044">bug 1323044</a>) &#8211; no progress yet, I expect some this month.</li>
</ul>
<p>Are there items we should be working on or looking into?  Please join <a href="https://wiki.mozilla.org/Auto-tools/Projects/Stockwell/Meetings">our meetings</a>.</p>
		<div class="wpcnt">
			<div class="wpa wpmrec">
				<a class="wpa-about" href="https://en.support.wordpress.com/about-these-ads/" rel="nofollow"></a>
				        <div id="crt-2073278343" style="width:300px;height:250px;"></div>
        <script type="text/javascript">
        var o = document.getElementById('crt-2073278343');
        if ("undefined"!=typeof Criteo) {
            var p = o.parentNode;
            p.style.setProperty('display', 'inline-block', 'important');
            o.style.setProperty('display', 'block', 'important');
            Criteo.DisplayAcceptableAdIfAdblocked({zoneid:388248,containerid:"crt-2073278343",collapseContainerIfNotAdblocked:true,"callifnotadblocked": function () {var o = document.getElementById('crt-2073278343'); o.style.setProperty('display','none','important');o.style.setProperty('visbility','hidden','important'); }
        });
        } else {
            o.style.setProperty('display', 'none', 'important');
            o.style.setProperty('visibility', 'hidden', 'important');
        }
        </script>
				<div class="u">
					<script type='text/javascript'>
					(function(g){if("undefined"!=typeof g.__ATA){g.__ATA.initAd({sectionId:26942, width:300, height:250});}})(window);
					</script>
				</div>
			</div>
		</div><div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-1440" class="share-google-plus-1 sd-button share-icon" href="https://elvis314.wordpress.com/2017/02/07/project-stockwell-february-2017/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-1440" class="share-twitter sd-button share-icon" href="https://elvis314.wordpress.com/2017/02/07/project-stockwell-february-2017/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-1440" class="share-facebook sd-button share-icon" href="https://elvis314.wordpress.com/2017/02/07/project-stockwell-february-2017/?share=facebook" target="_blank" title="Share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-7596067-1440-589a16f80656c' data-src='//widgets.wp.com/likes/#blog_id=7596067&amp;post_id=1440&amp;origin=elvis314.wordpress.com&amp;obj_id=7596067-1440-589a16f80656c' data-name='like-post-frame-7596067-1440-589a16f80656c'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>	</div><!-- .entry-content -->

	<div class="entry-links">
		<p class="comment-number"><a href="https://elvis314.wordpress.com/2017/02/07/project-stockwell-february-2017/#respond">Leave a comment</a></p>

					<p class="entry-categories tagged">Filed under <a href="https://elvis314.wordpress.com/category/uncategorized/" rel="category tag">Uncategorized</a></p>
			<p class="entry-tags tagged"></p>
			</div><!-- .entry-links -->

</div><!-- #post-## -->

<div id="nav-below" class="navigation">
	<div class="nav-previous"><a href="https://elvis314.wordpress.com/2017/01/09/project-stockwell-january-2016/" rel="prev"><span class="meta-nav">&larr;</span> Project Stockwell &#8211; January&nbsp;2016</a></div>
	<div class="nav-next"></div>
</div><!-- #nav-below -->


<div id="comments">

	
	
					<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/02/07/project-stockwell-february-2017/#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="https://elvis314.wordpress.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
					<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="67636f765b" /><input type="hidden" name="_wp_http_referer" value="/2017/02/07/project-stockwell-february-2017/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">

	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" title="Guest">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" title="WordPress.com">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" title="Twitter">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" title="Facebook">
					<span></span>
				</a>
			</li>
			<li>
			<iframe id="googleplus-sign-in" name="googleplus-sign-in" src="https://public-api.wordpress.com/connect/?googleplus-sign-in=https%3A%2F%2Felvis314.wordpress.com" width="24" height="24" scrolling="no" allowtransparency="true" seamless="seamless" frameborder="0"></iframe>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
				<p class="comment-form-posting-as pa-wordpress"><strong></strong> You are commenting using your WordPress.com account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
				<p class="comment-form-posting-as pa-twitter"><strong></strong> You are commenting using your Twitter account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
				<p class="comment-form-posting-as pa-facebook"><strong></strong> You are commenting using your Facebook account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
				<p class="comment-form-posting-as pa-googleplus"><strong></strong> You are commenting using your Google+ account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1440' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7b52c8ee96" /></p>
<input type="hidden" name="genseq" value="1486493432" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="100"/></p>				</form>
					</div><!-- #respond -->
		<div style="clear: both"></div>
</div><!-- #comments -->

	</div><!-- #content -->
</div><!-- #container -->


	<div id="sidebar" class="widget-area" role="complementary">
				<ul class="xoxo sidebar-list">

			<li id="text-2" class="widget widget_text"><h3 class="widget-title">whoami</h3>			<div class="textwidget">My real name is Joel Maher and as you can figure, I am a big fan of PI.  Many people know me by the nick elvis314 or jmaher.  Thanks for reading my blog</div>
		</li><li id="wp_tag_cloud-2" class="widget wp_widget_tag_cloud"><h3 class="widget-title"></h3><div style="overflow:hidden"><a href='https://elvis314.wordpress.com/tag/addons/' class='tag-link-106614 tag-link-position-1' title='2 topics' style='font-size: 9.8394160583942pt;'>addons</a>
<a href='https://elvis314.wordpress.com/tag/android/' class='tag-link-641922 tag-link-position-2' title='1 topic' style='font-size: 8pt;'>android</a>
<a href='https://elvis314.wordpress.com/tag/automation/' class='tag-link-44070 tag-link-position-3' title='20 topics' style='font-size: 18.423357664234pt;'>automation</a>
<a href='https://elvis314.wordpress.com/tag/browser-chrome/' class='tag-link-10638781 tag-link-position-4' title='1 topic' style='font-size: 8pt;'>browser-chrome</a>
<a href='https://elvis314.wordpress.com/tag/bugs/' class='tag-link-6354 tag-link-position-5' title='3 topics' style='font-size: 11.065693430657pt;'>bugs</a>
<a href='https://elvis314.wordpress.com/tag/business/' class='tag-link-179 tag-link-position-6' title='1 topic' style='font-size: 8pt;'>business</a>
<a href='https://elvis314.wordpress.com/tag/code/' class='tag-link-656 tag-link-position-7' title='7 topics' style='font-size: 14.131386861314pt;'>code</a>
<a href='https://elvis314.wordpress.com/tag/community/' class='tag-link-2528 tag-link-position-8' title='13 topics' style='font-size: 16.686131386861pt;'>Community</a>
<a href='https://elvis314.wordpress.com/tag/contribution/' class='tag-link-59800 tag-link-position-9' title='5 topics' style='font-size: 12.905109489051pt;'>contribution</a>
<a href='https://elvis314.wordpress.com/tag/data/' class='tag-link-22379 tag-link-position-10' title='5 topics' style='font-size: 12.905109489051pt;'>data</a>
<a href='https://elvis314.wordpress.com/tag/database/' class='tag-link-475 tag-link-position-11' title='1 topic' style='font-size: 8pt;'>database</a>
<a href='https://elvis314.wordpress.com/tag/debugging/' class='tag-link-70886 tag-link-position-12' title='2 topics' style='font-size: 9.8394160583942pt;'>debugging</a>
<a href='https://elvis314.wordpress.com/tag/development/' class='tag-link-780 tag-link-position-13' title='5 topics' style='font-size: 12.905109489051pt;'>development</a>
<a href='https://elvis314.wordpress.com/tag/fennec/' class='tag-link-663518 tag-link-position-14' title='35 topics' style='font-size: 20.875912408759pt;'>fennec</a>
<a href='https://elvis314.wordpress.com/tag/fennecmark/' class='tag-link-21459199 tag-link-position-15' title='3 topics' style='font-size: 11.065693430657pt;'>fennecmark</a>
<a href='https://elvis314.wordpress.com/tag/firefox/' class='tag-link-45 tag-link-position-16' title='1 topic' style='font-size: 8pt;'>firefox</a>
<a href='https://elvis314.wordpress.com/tag/geolocation/' class='tag-link-108693 tag-link-position-17' title='1 topic' style='font-size: 8pt;'>geolocation</a>
<a href='https://elvis314.wordpress.com/tag/gps/' class='tag-link-3169 tag-link-position-18' title='1 topic' style='font-size: 8pt;'>gps</a>
<a href='https://elvis314.wordpress.com/tag/graph-server/' class='tag-link-21542873 tag-link-position-19' title='1 topic' style='font-size: 8pt;'>graph server</a>
<a href='https://elvis314.wordpress.com/tag/gsoc/' class='tag-link-151852 tag-link-position-20' title='1 topic' style='font-size: 8pt;'>gsoc</a>
<a href='https://elvis314.wordpress.com/tag/hacking/' class='tag-link-1816 tag-link-position-21' title='2 topics' style='font-size: 9.8394160583942pt;'>hacking</a>
<a href='https://elvis314.wordpress.com/tag/hardware/' class='tag-link-79 tag-link-position-22' title='1 topic' style='font-size: 8pt;'>hardware</a>
<a href='https://elvis314.wordpress.com/tag/howto/' class='tag-link-1921 tag-link-position-23' title='7 topics' style='font-size: 14.131386861314pt;'>howto</a>
<a href='https://elvis314.wordpress.com/tag/idea/' class='tag-link-2933 tag-link-position-24' title='5 topics' style='font-size: 12.905109489051pt;'>idea</a>
<a href='https://elvis314.wordpress.com/tag/ideas/' class='tag-link-374 tag-link-position-25' title='1 topic' style='font-size: 8pt;'>Ideas</a>
<a href='https://elvis314.wordpress.com/tag/intermittent-failures/' class='tag-link-146336932 tag-link-position-26' title='4 topics' style='font-size: 12.087591240876pt;'>intermittent-failures</a>
<a href='https://elvis314.wordpress.com/tag/linkedin/' class='tag-link-80962 tag-link-position-27' title='3 topics' style='font-size: 11.065693430657pt;'>linkedin</a>
<a href='https://elvis314.wordpress.com/tag/manifest/' class='tag-link-24992 tag-link-position-28' title='1 topic' style='font-size: 8pt;'>manifest</a>
<a href='https://elvis314.wordpress.com/tag/manifests/' class='tag-link-44951 tag-link-position-29' title='1 topic' style='font-size: 8pt;'>manifests</a>
<a href='https://elvis314.wordpress.com/tag/mentoring/' class='tag-link-33253 tag-link-position-30' title='1 topic' style='font-size: 8pt;'>Mentoring</a>
<a href='https://elvis314.wordpress.com/tag/mobile/' class='tag-link-120 tag-link-position-31' title='15 topics' style='font-size: 17.197080291971pt;'>mobile</a>
<a href='https://elvis314.wordpress.com/tag/mochitest/' class='tag-link-23461774 tag-link-position-32' title='20 topics' style='font-size: 18.423357664234pt;'>mochitest</a>
<a href='https://elvis314.wordpress.com/tag/mozilla/' class='tag-link-24 tag-link-position-33' title='46 topics' style='font-size: 22pt;'>mozilla</a>
<a href='https://elvis314.wordpress.com/tag/notes/' class='tag-link-785 tag-link-position-34' title='7 topics' style='font-size: 14.131386861314pt;'>notes</a>
<a href='https://elvis314.wordpress.com/tag/numbers/' class='tag-link-6180 tag-link-position-35' title='1 topic' style='font-size: 8pt;'>numbers</a>
<a href='https://elvis314.wordpress.com/tag/people/' class='tag-link-660 tag-link-position-36' title='3 topics' style='font-size: 11.065693430657pt;'>People</a>
<a href='https://elvis314.wordpress.com/tag/perf/' class='tag-link-1054996 tag-link-position-37' title='1 topic' style='font-size: 8pt;'>Perf</a>
<a href='https://elvis314.wordpress.com/tag/perfherder/' class='tag-link-146339237 tag-link-position-38' title='1 topic' style='font-size: 8pt;'>PerfHerder</a>
<a href='https://elvis314.wordpress.com/tag/performance/' class='tag-link-1930 tag-link-position-39' title='10 topics' style='font-size: 15.56204379562pt;'>performance</a>
<a href='https://elvis314.wordpress.com/tag/performance-testing/' class='tag-link-11154 tag-link-position-40' title='1 topic' style='font-size: 8pt;'>performance testing</a>
<a href='https://elvis314.wordpress.com/tag/personal/' class='tag-link-64 tag-link-position-41' title='3 topics' style='font-size: 11.065693430657pt;'>personal</a>
<a href='https://elvis314.wordpress.com/tag/policy/' class='tag-link-13217 tag-link-position-42' title='1 topic' style='font-size: 8pt;'>policy</a>
<a href='https://elvis314.wordpress.com/tag/process/' class='tag-link-9719 tag-link-position-43' title='2 topics' style='font-size: 9.8394160583942pt;'>process</a>
<a href='https://elvis314.wordpress.com/tag/projects/' class='tag-link-2008 tag-link-position-44' title='1 topic' style='font-size: 8pt;'>projects</a>
<a href='https://elvis314.wordpress.com/tag/python/' class='tag-link-832 tag-link-position-45' title='1 topic' style='font-size: 8pt;'>python</a>
<a href='https://elvis314.wordpress.com/tag/qa/' class='tag-link-8841 tag-link-position-46' title='1 topic' style='font-size: 8pt;'>qa</a>
<a href='https://elvis314.wordpress.com/tag/random-orange/' class='tag-link-44877966 tag-link-position-47' title='1 topic' style='font-size: 8pt;'>random orange</a>
<a href='https://elvis314.wordpress.com/tag/rant/' class='tag-link-287 tag-link-position-48' title='1 topic' style='font-size: 8pt;'>rant</a>
<a href='https://elvis314.wordpress.com/tag/reftest/' class='tag-link-21460549 tag-link-position-49' title='6 topics' style='font-size: 13.620437956204pt;'>reftest</a>
<a href='https://elvis314.wordpress.com/tag/report/' class='tag-link-17573 tag-link-position-50' title='1 topic' style='font-size: 8pt;'>Report</a>
<a href='https://elvis314.wordpress.com/tag/scheduling/' class='tag-link-38754 tag-link-position-51' title='1 topic' style='font-size: 8pt;'>Scheduling</a>
<a href='https://elvis314.wordpress.com/tag/seta/' class='tag-link-86735 tag-link-position-52' title='1 topic' style='font-size: 8pt;'>SETA</a>
<a href='https://elvis314.wordpress.com/tag/sports/' class='tag-link-67 tag-link-position-53' title='1 topic' style='font-size: 8pt;'>sports</a>
<a href='https://elvis314.wordpress.com/tag/stair-climbing/' class='tag-link-4222456 tag-link-position-54' title='1 topic' style='font-size: 8pt;'>stair climbing</a>
<a href='https://elvis314.wordpress.com/tag/startup/' class='tag-link-4621 tag-link-position-55' title='1 topic' style='font-size: 8pt;'>startup</a>
<a href='https://elvis314.wordpress.com/tag/statistics/' class='tag-link-5849 tag-link-position-56' title='2 topics' style='font-size: 9.8394160583942pt;'>Statistics</a>
<a href='https://elvis314.wordpress.com/tag/talos/' class='tag-link-4148726 tag-link-position-57' title='14 topics' style='font-size: 16.992700729927pt;'>talos</a>
<a href='https://elvis314.wordpress.com/tag/technology/' class='tag-link-6 tag-link-position-58' title='1 topic' style='font-size: 8pt;'>technology</a>
<a href='https://elvis314.wordpress.com/tag/testdev/' class='tag-link-19937500 tag-link-position-59' title='38 topics' style='font-size: 21.182481751825pt;'>testdev</a>
<a href='https://elvis314.wordpress.com/tag/testing/' class='tag-link-12 tag-link-position-60' title='1 topic' style='font-size: 8pt;'>Testing</a>
<a href='https://elvis314.wordpress.com/tag/tests/' class='tag-link-2436 tag-link-position-61' title='1 topic' style='font-size: 8pt;'>tests</a>
<a href='https://elvis314.wordpress.com/tag/tip/' class='tag-link-30930 tag-link-position-62' title='1 topic' style='font-size: 8pt;'>tip</a>
<a href='https://elvis314.wordpress.com/tag/tips/' class='tag-link-1788 tag-link-position-63' title='8 topics' style='font-size: 14.642335766423pt;'>tips</a>
<a href='https://elvis314.wordpress.com/tag/tools/' class='tag-link-1981 tag-link-position-64' title='18 topics' style='font-size: 18.014598540146pt;'>tools</a>
<a href='https://elvis314.wordpress.com/tag/traffic/' class='tag-link-3967 tag-link-position-65' title='1 topic' style='font-size: 8pt;'>traffic</a>
<a href='https://elvis314.wordpress.com/tag/trends/' class='tag-link-518 tag-link-position-66' title='1 topic' style='font-size: 8pt;'>trends</a>
<a href='https://elvis314.wordpress.com/tag/unittests/' class='tag-link-5549356 tag-link-position-67' title='27 topics' style='font-size: 19.751824817518pt;'>unittests</a>
<a href='https://elvis314.wordpress.com/tag/webserver/' class='tag-link-28027 tag-link-position-68' title='1 topic' style='font-size: 8pt;'>webserver</a>
<a href='https://elvis314.wordpress.com/tag/wince/' class='tag-link-114931 tag-link-position-69' title='5 topics' style='font-size: 12.905109489051pt;'>wince</a>
<a href='https://elvis314.wordpress.com/tag/windows-mobile/' class='tag-link-1846 tag-link-position-70' title='18 topics' style='font-size: 18.014598540146pt;'>windows mobile</a>
<a href='https://elvis314.wordpress.com/tag/xpcshell/' class='tag-link-21822950 tag-link-position-71' title='9 topics' style='font-size: 15.153284671533pt;'>xpcshell</a></div></li><li id="archives-2" class="widget widget_archive"><h3 class="widget-title">Archives</h3>		<ul>
			<li><a href='https://elvis314.wordpress.com/2017/02/'>February 2017</a></li>
	<li><a href='https://elvis314.wordpress.com/2017/01/'>January 2017</a></li>
	<li><a href='https://elvis314.wordpress.com/2016/10/'>October 2016</a></li>
	<li><a href='https://elvis314.wordpress.com/2016/02/'>February 2016</a></li>
	<li><a href='https://elvis314.wordpress.com/2015/11/'>November 2015</a></li>
	<li><a href='https://elvis314.wordpress.com/2015/10/'>October 2015</a></li>
	<li><a href='https://elvis314.wordpress.com/2015/09/'>September 2015</a></li>
	<li><a href='https://elvis314.wordpress.com/2015/07/'>July 2015</a></li>
	<li><a href='https://elvis314.wordpress.com/2015/06/'>June 2015</a></li>
	<li><a href='https://elvis314.wordpress.com/2015/05/'>May 2015</a></li>
	<li><a href='https://elvis314.wordpress.com/2015/02/'>February 2015</a></li>
	<li><a href='https://elvis314.wordpress.com/2014/12/'>December 2014</a></li>
	<li><a href='https://elvis314.wordpress.com/2014/10/'>October 2014</a></li>
	<li><a href='https://elvis314.wordpress.com/2014/07/'>July 2014</a></li>
	<li><a href='https://elvis314.wordpress.com/2014/06/'>June 2014</a></li>
	<li><a href='https://elvis314.wordpress.com/2014/05/'>May 2014</a></li>
	<li><a href='https://elvis314.wordpress.com/2014/04/'>April 2014</a></li>
	<li><a href='https://elvis314.wordpress.com/2014/03/'>March 2014</a></li>
	<li><a href='https://elvis314.wordpress.com/2014/02/'>February 2014</a></li>
	<li><a href='https://elvis314.wordpress.com/2013/03/'>March 2013</a></li>
	<li><a href='https://elvis314.wordpress.com/2012/07/'>July 2012</a></li>
	<li><a href='https://elvis314.wordpress.com/2012/06/'>June 2012</a></li>
	<li><a href='https://elvis314.wordpress.com/2012/05/'>May 2012</a></li>
	<li><a href='https://elvis314.wordpress.com/2012/03/'>March 2012</a></li>
	<li><a href='https://elvis314.wordpress.com/2011/12/'>December 2011</a></li>
	<li><a href='https://elvis314.wordpress.com/2011/11/'>November 2011</a></li>
	<li><a href='https://elvis314.wordpress.com/2011/10/'>October 2011</a></li>
	<li><a href='https://elvis314.wordpress.com/2011/09/'>September 2011</a></li>
	<li><a href='https://elvis314.wordpress.com/2011/08/'>August 2011</a></li>
	<li><a href='https://elvis314.wordpress.com/2011/05/'>May 2011</a></li>
	<li><a href='https://elvis314.wordpress.com/2011/04/'>April 2011</a></li>
	<li><a href='https://elvis314.wordpress.com/2011/03/'>March 2011</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/11/'>November 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/10/'>October 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/07/'>July 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/06/'>June 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/05/'>May 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/04/'>April 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/03/'>March 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/02/'>February 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2010/01/'>January 2010</a></li>
	<li><a href='https://elvis314.wordpress.com/2009/12/'>December 2009</a></li>
	<li><a href='https://elvis314.wordpress.com/2009/11/'>November 2009</a></li>
	<li><a href='https://elvis314.wordpress.com/2009/09/'>September 2009</a></li>
	<li><a href='https://elvis314.wordpress.com/2009/08/'>August 2009</a></li>
	<li><a href='https://elvis314.wordpress.com/2009/07/'>July 2009</a></li>
	<li><a href='https://elvis314.wordpress.com/2009/06/'>June 2009</a></li>
	<li><a href='https://elvis314.wordpress.com/2009/05/'>May 2009</a></li>
		</ul>
		</li><li id="categories-422543811" class="widget widget_categories"><h3 class="widget-title">Categories</h3>		<ul>
	<li class="cat-item cat-item-2528"><a href="https://elvis314.wordpress.com/category/community/" >Community</a> (11)
</li>
	<li class="cat-item cat-item-54"><a href="https://elvis314.wordpress.com/category/general/" >general</a> (15)
</li>
	<li class="cat-item cat-item-113450"><a href="https://elvis314.wordpress.com/category/intermittents/" >intermittents</a> (1)
</li>
	<li class="cat-item cat-item-64"><a href="https://elvis314.wordpress.com/category/personal/" >personal</a> (4)
</li>
	<li class="cat-item cat-item-8841"><a href="https://elvis314.wordpress.com/category/qa/" >qa</a> (4)
</li>
	<li class="cat-item cat-item-309"><a href="https://elvis314.wordpress.com/category/reviews/" >reviews</a> (5)
</li>
	<li class="cat-item cat-item-19937500"><a href="https://elvis314.wordpress.com/category/testdev/" >testdev</a> (59)
</li>
	<li class="cat-item cat-item-1"><a href="https://elvis314.wordpress.com/category/uncategorized/" >Uncategorized</a> (53)
</li>
		</ul>
</li><li id="linkcat-1356" class="widget widget_links"><h3 class="widget-title">Blogroll</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://cacaolab.wordpress.com/directory-of-artisan-chocolate-makers/" rel="friend met colleague" title="For all you Chocolate fanatics">Cacao Lab</a></li>
<li><a href="http://cmtalbert.wordpress.com/" rel="friend met co-worker" title="Water on Rock &#8211; More mozilla testdev goodness">Clint Talbert &#8211; Mozilla testdev</a></li>
<li><a href="http://zadkielm.blogspot.com/" rel="friend co-worker" title="A great wealth of tidbits on software development and a lot of Mozilla and Fennec">Evmarbella&#039;s Web Log</a></li>
<li><a href="http://sebasti1.wordpress.com/" rel="friend met co-worker" title="Many postings related to software development including work on Mozilla and Fennec">Happyhans</a></li>

	</ul>
</li>
		</ul>
	</div><!-- #sidebar .widget-area -->

	
		</div><!-- #content-box -->

		<div id="footer" role="contentinfo">
			<div id="colophon">

				
				<div id="site-info">
					<a href="https://elvis314.wordpress.com/" title="3.1415926535897932384626433&#8230;" rel="home">3.1415926535897932384626433&#8230;</a> &middot; PI, pie, and py				</div><!-- #site-info -->

				<div id="site-generator">
					<a href="https://wordpress.com/?ref=footer_website">Create a free website or blog at WordPress.com.</a>				</div><!-- #site-generator -->

			</div><!-- #colophon -->
		</div><!-- #footer -->
	</div><!-- #page .blog -->
</div><!-- #container -->

<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201706y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/elvis314.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/elvis314.wordpress.com\/wp-login.php?action=logout&_wpnonce=482d9cf577","homeURL":"https:\/\/elvis314.wordpress.com\/","postID":"1440","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"0","userIsLoggedIn":"","isJetpack":"0","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/elvis314.wordpress.com\/2017\/02\/07\/project-stockwell-february-2017\/":1440};
	</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-google-plus-1' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
		<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/akismet-3.0/_inc/form.js?m=1404442431h'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"7596067","siteName":"3.1415926535897932384626433...","siteURL":"http:\/\/elvis314.wordpress.com","icon":"<img alt='' src='https:\/\/s1.wp.com\/i\/logo\/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/pilcrow","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/elvis314.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Felvis314.wordpress.com%2F2017%2F02%2F07%2Fproject-stockwell-february-2017%2F","themeURL":"","xhrURL":"https:\/\/elvis314.wordpress.com\/wp-admin\/admin-ajax.php","nonce":"6915945b46","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"31638af329\" \/>","referer":"https:\/\/elvis314.wordpress.com\/2017\/02\/07\/project-stockwell-february-2017\/","canFollow":"1","statusMessage":"","customizeLink":"https:\/\/elvis314.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Felvis314.wordpress.com%2F2017%2F02%2F07%2Fproject-stockwell-february-2017%2F","postID":"1440","shortlink":"http:\/\/wp.me\/pvS5d-ne","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/elvis314.wordpress.com\/1440","statsLink":"https:\/\/wordpress.com\/stats\/post\/1440\/elvis314.wordpress.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Pilcrow","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in the Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/elvis314.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Felvis314.wordpress.com%2F2017%2F02%2F07%2Fproject-stockwell-february-2017%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJx9jEESwiAMRS8kzTgWx43jWRBimwoBA1S9vXTRjquu8ifv/wfvpGzkglxgyuBwJovp0035AH8oVJV8HYgzeHpihlfFiqNh51HWMrH11TXYRDaG0IZKMPlvF4h3jMY1ru5GIJhcUFpScUYRWmTbb89gC0VeDFvaaaeYi3p4QwJ5NEI8rLeNbuF67C9a9/35pKcf/wlq+A=='></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>	<script type="text/javascript">
	var skimlinks_pub_id = "725X584219"
	var skimlinks_sitename = "elvis314.wordpress.com";
	</script>
	<script type="text/javascript" defer src="https://s.skimresources.com/js/725X1342.skimlinks.js"></script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20170206#ver=20170206' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
		<script>
			var _comscore = _comscore || [];
			_comscore.push({
				c1: "2",
				c2: "7518284"
			});
			(function() {
				var s = document.createElement("script"),
					el = document.getElementsByTagName("script")[0];
				s.defer = true;
				s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
				el.parentNode.insertBefore(s, el);
			})();
		</script>
		<noscript>
			<p class="robots-nocontent"><img src="https://sb.scorecardresearch.com/p?c1=2&c2=7518284&c3=&c4=&c5=&c6=&c15=&cv=2.0&cj=1" alt="" style="display:none;" width="1" height="1" /></p>
		</noscript><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'7596067','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'7596067','v':'wpcom','tz':'-4','user_id':'0','post':'1440','subd':'elvis314'}]);
_stq.push(['extra', {'crypt':'UE5XaGUuOTlwaD85flAmcm1mcmZsaDhkV11YdWFnNncxc1tjZG9XVXhRREQ/V0xPZ1hKXy9tT2NrSFYrY21oVW8/aUJWS3VbSUw4amxjLjZzM0ViWUdVSzZxZ0xDODBzU3dseGF2Z3Aldm83QXZkRTF1bTlFUls0dEhPVF89QXU2Zi13U1BnZGMsYy96R01rTWYlNXBFPzBBWnkra1tySmk3OF8vJlNReFBVdEdEeUV2ZWZ3W2ZMdVFiQS58dTFLQmNhVy1sLCtsWmsmMU0zRE92YjlLfndRVDhbRCxhUS9EcG5YMngtbTVUTXFRaXE1UTcyVVY3UFArdUEsVyU='}]);
_stq.push([ 'clickTrackerInit', '7596067', '1440' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>
